Warwick Rockbass 2007 Electronics

Joined
Dec 1, 2020
Messages
2
Reaction score
0
Age
50
Hello there.
I'm new to the forum and hope someone can give me an advice.

I recently bought a Warwick Rockbass Corvette std 5 fretless. Very nice instrument.

When doing the cleaning, trying to get a knob out, one of the pots was damaged.
Also, another pot which I believe been balance pot (pickup blend) is not working properly.
And I'm kind of trouble to identity between volume and balance pots as they are not working correctly.
Treble and bass pots are working correctly, but not sure if it's an error or problem, the position of the pots are different on this bass from my Wick Corvette $$ 5 German.
Treble pot is the one closer to the bridge on this, where on the $$ is the bass.

I need to identify the value of the pots to replace but no luck searching the web.
The circuit has the following lable:
RBA04Q-GREE - 2 Band EQ

20201204_165821.jpg
20201202_021406.jpg
122109225_10217981734194217_515051002777752450_o.jpg

Attached some pics that may help.
Thanks!
 
Joined
Dec 1, 2020
Messages
2
Reaction score
0
Age
50
After some further investigation I discovered the circuit actually seems to be modified and there is no balance/volume pots but a volume pot for each PuP.
replaced the defective pot but now it seems another problem: The bass pot, when in full gain distorts really bad the sound.
Treble pot seems works, but can't expect too much treble gain with flat-wounds on a fretless.

Does anyone has a (correct) diagram for that circuit? I found a couple on the web but none matches with the current circuit configuration/wiring.

Thanks!
 
Top Bottom