Pro Tube IV problem

Joined
Feb 13, 2007
Messages
92
Reaction score
0
I have a Pro Tube IV 8 months old. Tone control (tube side) makes this popping and squealing sound, very very loud, when turned in any direction. It almost sounds like speaker damage may result if I dont stop immediately turning the dial. Theres new tubes in there. Bad control or a problem with the tone circuit?? Anyone have an idea what this problem might be? Warranty was only 3 months so I may be paying for this repair however I need to find a qualified tech to correctly troubleshoot it without excessive parts changing or guess work.
 
Joined
Sep 10, 2006
Messages
3,469
Reaction score
4
Age
31
sounds to me like a dirty pot...

edit: im not a qualified tech though its just in myexperience dirty pot tend to make the poppy/scrapy sound
 
O

odominguez

Guest
vakmere said:
I have a Pro Tube IV 8 months old. Tone control (tube side) makes this popping and squealing sound, very very loud, when turned in any direction. It almost sounds like speaker damage may result if I dont stop immediately turning the dial. Theres new tubes in there. Bad control or a problem with the tone circuit?? Anyone have an idea what this problem might be? Warranty was only 3 months so I may be paying for this repair however I need to find a qualified tech to correctly troubleshoot it without excessive parts changing or guess work.

It could easily be a dirty pot, but I strongly suggest taking your bass to a qualified tech.
 
Top Bottom