Dismiss Notice
Join The Good Vibe Zone today, and hangout with the nicest bass community in the world :)

Hellborg Poweramp - Should There Be A Harmonic Distortion Under The Clean Tone?

Discussion in 'Non - Official Warwick Customer Support' started by willplaysbass, Oct 30, 2018.

  1. willplaysbass

    willplaysbass

    Joined:
    Oct 30, 2018
    Messages:
    4
    Likes Received:
    5
    Trophy Points:
    3
    Hi, new to the forum... not sure if this is the best place to post this Would welcome any help or advice...

    My question is for warwick or other hellborg users. Do you get a harmonic type distortion that sits under the crystal clear note when using the Hellborg Mono 500? I have the matching hellborg preamp too, and have identified that it is definitely the power amp that adds this "character".

    Is it part of the tube like sound? I must admit I dont mind it - its actually quite nice but just want to know if I should get it looked incase it's an issue that will get worse.

    I tried the amp throught the hellborg 2x12 cab when I got it and didn't notice it - I know have a trickfish 210v so wondering if its maybe the cab choice im using?

    I did see on basschat a post from another bass player complaining about this but no amp tech could see there was a problem with his mono 500 - so wondering if it should be like this and just me and this other bass player have exceptional hearing!! haha

    Thanks in advance for any help!
     
  2. Florin

    Florin Warwick Forum Administrator Staff Member

    Joined:
    Oct 28, 2006
    Messages:
    17,713
    Likes Received:
    1,644
    Trophy Points:
    114
    No, Hellborg Gear should be crystal clear, even with a fair amount of overload (red led clipping)
     
    Hardy likes this.
  3. willplaysbass

    willplaysbass

    Joined:
    Oct 30, 2018
    Messages:
    4
    Likes Received:
    5
    Trophy Points:
    3
    Thanks Florin,

    It's probably best I take it to a tech but I will try it with a different cab also just incase. I noticed that when I crank the Hi-mid and Treble on the preamp the distortion does seem to disappear or maybe I just can't hear it. I know the preamp is fine as I have tried it with other amps and DI'd.

    Love the amp regardless! Maybe I should hunt down a 2x12 or take a look at the new warick cabs!
     
  4. Hardy

    Hardy Good Vibe Sponsor

    Joined:
    May 23, 2008
    Messages:
    4,859
    Likes Received:
    2,405
    Trophy Points:
    113
    Location:
    South-Bassmania
  5. willplaysbass

    willplaysbass

    Joined:
    Oct 30, 2018
    Messages:
    4
    Likes Received:
    5
    Trophy Points:
    3
    Oh haha! How much would you want for the 2x12 and where in the world are you? I'm in sunny Wales.
     
  6. Hardy

    Hardy Good Vibe Sponsor

    Joined:
    May 23, 2008
    Messages:
    4,859
    Likes Received:
    2,405
    Trophy Points:
    113
    Location:
    South-Bassmania
    Gerrrmany! Both cabs are 1x15 btw, I only want to seel all stuff together. In case you need another power amp... but I hope everything is fine with yours!
     
  7. Florin

    Florin Warwick Forum Administrator Staff Member

    Joined:
    Oct 28, 2006
    Messages:
    17,713
    Likes Received:
    1,644
    Trophy Points:
    114
    It might be the cab, you know, even a lose screw, or a rattling wire inside can cause this. When you own both the Hellborg Pre and Power amp, you expect everything to be clean, but the truth is rarely I've seen a perfectly clean sounding cab. Hellborg cab configuration Hardy is letting go is studio quality :)
     
  8. Florin

    Florin Warwick Forum Administrator Staff Member

    Joined:
    Oct 28, 2006
    Messages:
    17,713
    Likes Received:
    1,644
    Trophy Points:
    114
    Also try switching ground lift around. If both the pre and power amp are linked to ground you may get some noise, and I thought it was distortion myself when it happened.
     
  9. Hardy

    Hardy Good Vibe Sponsor

    Joined:
    May 23, 2008
    Messages:
    4,859
    Likes Received:
    2,405
    Trophy Points:
    113
    Location:
    South-Bassmania
    I use a Reußenzehn all tube amp as pre to get tube sound, indeed the Hellborg stuff has to be clear as crystal.
     
  10. Florin

    Florin Warwick Forum Administrator Staff Member

    Joined:
    Oct 28, 2006
    Messages:
    17,713
    Likes Received:
    1,644
    Trophy Points:
    114
    I used to use some tube pedal, or DE B7k, or EL Distressor in the FX loop of the Hellborg Pre to add some distortion :)
     
Loading...